用户工具

站点工具


irouter:net:duolan

返回首页

内网多LAN接入

多LAN分为以下几种情况:

  • 1. 独立的多LAN口:每个LAN口有自己的IP,且不同网段

    每个LAN口接不同的设备,如交换机或服务器,如果LAN口下的终端是DHCP上网,需要为这个LAN添加IP地址池(默认地址池只对LAN1分配)

  • 2. 多LAN口汇聚:多个网口汇聚成一个LAN口使用,共用一个IP

    LAN口网卡都接到同一个交换机上,同时交换机上也需开启端口汇聚,可实现带宽叠加和故障转移。

  • 3. 多LAN口网桥:多个网口桥接在一起,共用一个IP

    LAN口网卡都在同一个网段,相当于处于一个大的交换机下。每个网口可以接不同的设备,但不能将2个网口接到同一个交换机上,否则回形成环路。

独立的多个LAN口

第一步:绑定多个LAN口到物理网卡,名字可以自定义,如 lan2,lan3 …

第二步:为每个LAN口配置IP

IP不能和其他LAN口重复或在同一网段

第三步:

3.1 为LAN口设置DHCP IP分配地址池(可选)

3.2 PPPoE 服务增加监听网卡(可选)

修改网卡后,需要重启PPPoE服务生效,重启服务时,当前已连接的用户会断线重播。

多LAN - 端口汇聚

七种汇聚模式:

  • 0 - Round-robin policy(平衡轮循环)
  • 1 - Active-backup(主-备份)
  • 2 - Balance XOR(平衡)
  • 3 - Broadcast(广播)
  • 4 - 802.3ad LACP 动态链接聚合(默认/最常用)
  • 5 - Adaptive transmit load balancing(适配器传输负载均衡)
  • 6 - Adaptive load balancing(适配器适应性负载均衡)

汇聚模式选择

  • 若交换机/OLT支持LACP动态聚合,选模式4,如华为/H3C交换机、华为OLT多用此模式;
  • 若交换机/OLT只支持LACP静态聚合,选模式0/2/3,首选0;如 锐捷RG-NBS5200、傻瓜EPON OLT 用模式0;
  • 汇聚模式5/6不需要交换机端支持,其他模式则需要在交换机上配置聚合。

在物理网卡绑定时,选择汇聚或汇聚网桥类型:

汇聚成功后在首页可以看到汇聚状态:

交换机上的设置(以H3C S5720为例):

<switch>
<switch>sys        # 切换到system view 视图
[switch]

### 创建汇聚组1(接路由器)
interface Eth-Trunk1
 description Linked to Router
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094
 mode lacp

### 创建汇聚组2(接OLT)
interface Eth-Trunk2
 description Linked to OLT
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094
 mode lacp

### 端口1和2加入汇聚组1
interface GigabitEthernet0/0/1
 eth-trunk 1
interface GigabitEthernet0/0/2
 eth-trunk 1

### 端口23和24加入汇聚组2
interface GigabitEthernet0/0/23
 eth-trunk 2
interface GigabitEthernet0/0/24
 eth-trunk 2


## 端口10接服务器,access vlan 100
interface GigabitEthernet0/0/10
port link-type access
port default vlan 100

## 设置完成后退出sys视图,保存配置!!重要!!
[switch]quit
<switch>save 
输入Y确认

多LAN口网桥

此类型用的较少,和单LAN网桥类似,只是绑定多个网卡。

LAN口网桥主要用于KVM虚拟机的场合,虚拟机的虚拟网卡和物理网卡桥接,更多参考 虚拟机网络类型

汇聚网桥

多个LAN先汇聚,提供冗余及加倍带宽,然后基于汇聚设备创建网桥,可以和虚拟机桥接。

irouter/net/duolan.txt · 最后更改: 2022/09/08 15:46 由 muddyboot

Copyright © 2014-2020 版权所有 (MoreQuick Networs Co., Ltd. All rights reserved)
本系统由 秒开 iRouter & 在阿里云上强力驱动